The plays that you create in FastDraw are saved in a file that is stored on the hard drive of your computer. Because of this, your plays can be susceptible to hard drive crashes, computer theft, or updates made by your IT department. To protect your work, we recommend frequently Syncing your plays to the FastModel Sports cloud server. This file can always be recovered by you or by a member of the FastModel Support team, should any of your plays ever go missing.

 

If you find yourself currently missing any plays or playbooks that you have created, and you have not previously Synced your plays to the cloud server, there are a few steps that you can take to try and recover your plays.

 


Resizing the Play Library Window

When you have the Draw tab activated in FastDraw, you should see the Play Library window on the left side, and the Play Editor on the right side. These windows can be resized, and it's possible for the Play Library window to occasionally be reduced in size to the point where you can no longer see any of your plays. If you are experiencing this issue, simply adjust the size of your windows to reveal your Play Library window.

 

Screen Shot 2016-09-20 at 12.14.52 PM.png


 


Checking your Play Filters

If your Play Library is visible in the Draw tab, but you do not see any plays available, you will want to check your Play Filters to ensure that you have not inadvertently turned on an empty filter. Making sure that your Season, Team, and Series filters are all set to <All> (see this article) will display any and all plays that are currently available in your library.

 

In addition to checking your Play Filters, be sure that you have not inadvertently created a Play as a Building Block, or vice versa. You can switch between Plays and Building Blocks using the tabs on the left side of the Play Library window.

 

 

 


Missing FastDraw Save File

If you have checked your Play Filters and determined that there currently are not any plays in your library, then it is possible that your save file is no longer saved on your computer. The most frequent cause of your save file missing from your hard drive is if your IT department has made an update to your computer that has wiped your computer's hard drive. If you believe that this may have happened, it is still possible that your IT department made copies of the files on your computer before making the update. Please reference this article for information on where your FastDraw save file is located.

 


 

If you are able to locate this save file, you can transfer it back on to your current hard drive and save it in any location. You can then open the file in FastDraw by clicking the File menu from the top menu bar and selecting Open File.

 

 

 

Local Backups

If no changes have been made to your computer's hard drive, or if you are trying to locate plays or playbooks that you have deleted, you can check the Local Backup copies of your save file for earlier versions of the file that might contain the plays you are looking for. When you are working in FastDraw, your file will auto-save to your Local Backups folder every 5 minutes when it detects new changes to your save file. To examine the contents of your Local Backups, open the file menu from the top menu bar in FastDraw and select Import from Backup.



 

This will automatically take you to your Local Backups folder, where all of your available Backup files will be listed. You can sort these files by name, as they are named by date and time, or you can sort by Date Modified, both of which will allow you to see your files in chronological order. This can help you locate a file from when you last remember being able to access the plays or playbooks that you are looking for.



 

After you have selected a file, FastDraw will analyze the contents of the file and present you with the Import/Synchronize FastDraw Files menu.

 


 

Any plays that are highlighted in green are plays that are present in the older file, but not present in your current file. If you have deleted plays unintentionally or are looking for any plays that have gone missing, the plays marked in green are generally going to be the ones you are looking for. These plays will automatically be selected with a check mark next to each one. If you wish to import every play highlighted in green, simply click the Import of Synchronize Selected Plays button. If you want to individually select which plays to import, you can scroll through the list and check or un-check more plays.

 

Any plays highlighted in red are plays that are present in both the old file and the current file, but more recent changes have been made to the play in the current file, making the play marked in red out of date. You can check the Last Modified date listed to confirm when changes were made to the play in both the current file and the old file.